请选择 进入手机版 | 继续访问电脑版
发帖
开启辅助访问
 找回密码
 立即注册
取消
搜索
热搜:
活动 交友 discuz
分享到

Windows 10 1903 版本可能会导致远程桌面显示黑屏

#技术分享#时间:2019-07-16 阅读:676 回复:1

131

主题

201

帖子

4741

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
4741
原文标题:Windows 10 1903 May Show Black Screen in Remote Desktop
原文作者: Lawrence Abrams
译文出自:云子可信官方论坛
译者:云子可信汉化组





7月9日,微软推出了针对Windows10的新版本1903。新版本发布一周不到,即7月14日,Microsoft已在Windows 10 1903版本中的已知问题列表中添加了一个新错误,该问题为当使用旧的图形驱动程序时远程桌面连接会显示黑屏。

具体的漏洞报告:当用户通过远程桌面连接到具有某些旧GPU驱动程序的设备(包括Intel 4系列集成的GPU驱动程序)时,将显示黑屏。

“当使用一些旧的GPU驱动程序启动与设备的远程桌面连接时,您可能会遇到黑屏的情况。任何版本的Windows在启动与运行受影响显示驱动程序的1903版本Windows 10设备(包括Intel 4系列芯片集集成GPU(IGPU)的驱动程序)的远程桌面连接时都可能遇到此问题。”

微软已经声明,这个错误第一次出现在2019年5月29日发布的KB4497935(内部版本18362.145)中,并从那时起影响到Windows10 1903版本。期间的这几个版本的远程桌面都可能会出现黑屏的情况。

一个受此漏洞影响的用户发布了一个截屏,显示了当试图通过远程桌面连接到受影响的设备时的情况。



远程桌面黑屏情况



如果您受到此问题的影响,导致您不能使用远程桌面,您可以尝试更新GPU驱动程序,看看是否有帮助。如果没有,微软已经声明将在未来的更新中解决远程桌面黑屏的问题。

这个Bug是微软上周添加的3个Bug之一。另外宣布的错误是,如果使用预引导执行环境(PXE)引导,会导致设备无法启动。另外一个错误是,Nvidia离散图形处理单元(DGPU)偶现的问题。

在此问题得到解决之前,微软建议Surface Book 2用户避免使用Media Creation Tool或其他强制方法升级到Windows 10 1903版本。
微软目前还为提供良好的处理这个远程桌面漏洞的方案,其实为了避免远程桌面黑屏的情况发生,现在完全可以使用第三方软件来实现远程桌面,比如接下来为大家介绍的云子可信远程桌面软件,远程黑屏不再困扰。



云子可信远程桌面软件

云子可信终端管理是老牌安全厂商、上市企业——北京启明星辰旗下的正规产品,产品上线前都会经过多项严格测试,保证产品安全。同时云子可信远程桌面功能支持企业内网远程和异地外网远程;支持网页端远程和主控客户端远程两种远程桌面方式;可选择远程桌面的模式;远程会话帧率高达 60fps,为您提供最优质的远程桌面体验!



回复
使用道具 举报
| 匿名  发表于 2019-7-28 19:23:26
If you're hitting a black screen with RDP connections on Windows 10 Build 1903, then the following workaround submitted by user Charles O might be helpful:

As you might recall installing 1903 (WIN 10) on an older PC with certain chipsets resulted in a black screen while using RDP. Jump got the black screen too (obviously). This is a known issue, discussed by Microsoft as late as July 12th and still awaiting the fix (promised for July-August).

The black screen issue has to do with a new display driver (WDDM) used in 1903. The “fix” forces the old XDDM driver to be used. From what I understand it isn’t just the display adapter that causes the issue with affected chipsets, so putting a new video card in the machine won’t help.

Simple fix! Use GPO to force use of XDDM rather than WDDM. In Group Policy Editor under Remote Desktop Session Host -> Remote Session Environment ... set the policy “Use WDDM graphics display driver for Remote Desktop Connections” to DISABLED.

Worked for me on three machines. No side affects that I see.
回复
使用道具
快速回复
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

客服电话
173-6185-1240
发布 快速回复 返回顶部 返回列表